Unknown USB Device (Device Descriptor Request Failed)


#1

Hi there,
I’m having troubles getting my Looking Glass to work correctly. When I plug in the USB cable I get a notification saying the USB device isn’t recognized. Clicking the notification gives the following message:

As you can also see in the above screenshot, the device is listed as “Unknown USB Device (Device Descriptor Request Failed)”. Opening Properties>General shows the following device status:

Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.

I have tried connecting to all other USB 3.0 ports with no success, as well as restarting the computer.

The following events are listed for the device in the Event Viewer (I tried attaching screenshots but the forum would let me attach at most one):

Error
Device USB\VID_0000&PID_0002\6&38bb4840&0&3 had a problem starting.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Service:
Lower Filters:
Upper Filters:
Problem: 0x2B
Problem Status: 0x0

Information
Device USB\VID_0000&PID_0002\6&38bb4840&0&3 was configured.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.17134.1
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\VID_05E3&PID_0608\5&1e313dec&0&3

Warning
Device USB\VID_0000&PID_0002\6&38bb4840&0&3 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\VID_04D9&PID_0169\6&fda2ede&0&2
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Location Path:
Migration Rank: 0xF000FFFFFFFFF120
Present: false
Status: 0xC0000719

Let me know if you need any other info or want me to try anything else.


#2

I just tried it with a MacBook Pro and I couldn’t get it to work there either. I could buy a replacement USB-C coord to see if that is the problem, otherwise I guess I have a faulty unit?


#3

Heya,

Likely your cable is fine. If you have access to another one to test from a friend it might be worth checking but otherwise this seems like it might be a defective unit; it isn’t even detecting the correct USB vendor and product identifiers.

What was the error message on the Mac?

Finally - can you let us know if the light turns on when you press the button when the USB is plugged in? Does it function properly as an HDMI display?

We’ll tag up with you over email regardless. Apologies for the trouble!


#4

Hey, thanks for the response. The side light turns on as soon as I plug in the USB cable, the buttons don’t seem to do anything. It works as a display over HDMI, I see my desktop. (same on Win and Mac)

I might be able to borrow another cable tomorrow, I’ll get back to you about the results.

The following is the result of running “system_profiler SPUSBDataType” in the terminal on the Mac. It looks like the device isn’t listed.

USB:

USB 3.0 Bus:

  Host Controller Driver: AppleUSBXHCILPTH
  PCI Device ID: 0x8c31 
  PCI Revision ID: 0x0005 
  PCI Vendor ID: 0x8086 

    Apple Internal Keyboard / Trackpad:

      Product ID: 0x0274
      Vendor ID: 0x05ac (Apple Inc.)
      Version: 6.24
      Serial Number: D3H81220561FTV4AH4PF
      Speed: Up to 12 Mb/sec
      Manufacturer: Apple Inc.
      Location ID: 0x14400000 / 3
      Current Available (mA): 500
      Current Required (mA): 500
      Extra Operating Current (mA): 0
      Built-In: Yes

    Bluetooth USB Host Controller:

      Product ID: 0x8290
      Vendor ID: 0x05ac (Apple Inc.)
      Version: 1.66
      Speed: Up to 12 Mb/sec
      Manufacturer: Broadcom Corp.
      Location ID: 0x14300000 / 6
      Current Available (mA): 500
      Current Required (mA): 0
      Extra Operating Current (mA): 0
      Built-In: Yes

    USB Receiver:

      Product ID: 0xc52f
      Vendor ID: 0x046d  (Logitech Inc.)
      Version: 16.00
      Speed: Up to 12 Mb/sec
      Manufacturer: Logitech
      Location ID: 0x14200000 / 5
      Current Available (mA): 500
      Current Required (mA): 98
      Extra Operating Current (mA): 0

    USB2.0 Hub:

      Product ID: 0x0608
      Vendor ID: 0x05e3  (Genesys Logic, Inc.)
      Version: 85.36
      Speed: Up to 480 Mb/sec
      Location ID: 0x14100000 / 29
      Current Available (mA): 500
      Current Required (mA): 100
      Extra Operating Current (mA): 0

#5

Hi! While we’re debugging this issue with you, I can send you your calibration backup file so you can at least start playing with your Looking Glass. Your buttons still wouldn’t be active, but the visuals would be right and that’d at least buy us a little time for the full debug or repair.

If this works for you, please email me the serial number of your system on the label on the back of your Looking Glass and then I’ll send you the backup. shawn@lookingglassfactory.com

We’ll get this sorted and get you up and running one way or another!

-Shawn


#6

Thanks a lot, that would be great! I have replied to your email with the serial nr.