Unity: LKG keeps choosing Display 1 instead of Display 2 when playing

Issue:
Unity: LKG keeps choosing Display 1 instead of Display 2 when playing. I cannot find any solution to fix this issue. I’m also using the Extended UI and it was set to Display 1. And LKG was set to Display 2. But when I play or build, it keeps going back to Display 1. It only happens yesterday, but I didn’t change anything in the setting of HoloPlay component and Extended UI.

My workaround is: turn on/off the Background Camera inside Extended UI for several times, then everything get back to normal.

Please help.

Miller Nguyen

1 Like

Hi Miller, sorry you’re having this issue! Do you mind mentioning which version of the HoloPlay Unity Plugin and which version of Unity you’re using?

Unity 2019.4 (LTS)
HoloplaySDK-1.3.1

I suspect the issue is come from ExtendedUI, it overwrites the Camera on Holoplay. When I turn off ExtendedUI, everything is back to normal.

Do you have any demo of 2 or 3 LKG in one scene? I’d like to connect 2 or 3 LKG to one PC.

Thanks.