Unity got frozen when trying to show scene on LKG

Hi. Thanks for reading.

I tried to use Looking Glass with Unity, but some trouble occurs.

trouble(1)
When I opened a Unity project with Looking Glass plugin imported, Holoplay Service suddenly finished.
And I found following error message on console tab.

[Error] Client access error (code = hpc_CLIERR_PIPEERROR): Interprocess pipe broken. Check if HoloPlay Service is still running!
UnityEngine.Debug:Log(Object)
LookingGlass.PluginCore:PrintError(hpc_client_error) (at Assets/Holoplay/Scripts/PluginCore.cs:210)
LookingGlass.PluginCore:InitHoloPlayCore() (at Assets/Holoplay/Scripts/PluginCore.cs:111)
LookingGlass.PluginCore:GetLoadResults() (at Assets/Holoplay/Scripts/PluginCore.cs:128)
LookingGlass.Preview:CloseExtraHoloplayWindows() (at Assets/Holoplay/Scripts/Editor/Preview.cs:174)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions() (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:200)

[Error] Client access error (code = hpc_CLIERR_PIPEERROR): Interprocess pipe broken. Check if HoloPlay Service is still running!
UnityEngine.Debug:Log(Object)
LookingGlass.PluginCore:PrintError(hpc_client_error) (at Assets/Holoplay/Scripts/PluginCore.cs:210)
LookingGlass.PluginCore:GetLoadResults() (at Assets/Holoplay/Scripts/PluginCore.cs:162)
LookingGlass.Preview:CloseExtraHoloplayWindows() (at Assets/Holoplay/Scripts/Editor/Preview.cs:174)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions() (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:200)

trouble(2)
Errors on trouble (1) clearly showed that Holoplay Service was not running, So I re-launched Holoplay Service.
Then I opened a examples scene “Holoplay/Examples/1 - Framing Content with Holoplay”, and tried to show preview by cliking “Hierarchy>Holoplay Capture>Toggle Preview Ctrl + E”.
At this moment, Unity got frozen and didn’t respond for long time, so I force-quit Unity.

Environment:

  • Windows10
  • Looking Glass 8.9""
  • Holoplay Service 1.1.2
  • HoloPlay Unity Plugin for the Looking Glass 1.3.1
  • Unity 2018.4.26f1(LTS) … I also tried Unity 2019.3.11f1

Display setting:
1st display … PC’s display
2nd display … Looking Glass(2560*1600)
screen extened, and Looking Glass is aligned on the left top of 1st display.

Others:
When I Tried “Holoplay Service > Display 0:8.9” Looking Glass > show window", Logo was shown properly.

How can I resolve these?
I appreciate your help!

Hi @Shota.O,

Sorry that you’re experiencing this! It’s actually a known bug and will be fixed in next release of HoloPlay Service.
To help us fix this bug, can you tell us if you have multiple Windows user accounts on the computer? Thank you!

Hi, @kelly,

Thanks for response!
regarding Windows User, I don’t have multiple users on my computer.

thank you for your cooperation!

Hi @Shota.O, wanted to check back in here. Are you up and running now or do you need additional support?