Unity 2018.2


#1

I tried importing the package into a clean project in Unity 2018.2 and the built scene would not work. When I rolled back to 2017.4.8f1 it worked fine.

Error is:
ArgumentNullException: Argument cannot be null.
Parameter name: shader
UnityEngine.Material…ctor (UnityEngine.Shader shader) (at C:/buildslave/unity/build/Runtime/Export/Shader.bindings.cs:104)
HoloPlay.Quilt.SetupQuilt () (at Assets/HoloPlay/Core/Scripts/Quilt.cs:377)
HoloPlay.Quilt.ApplyPreset () (at Assets/HoloPlay/Core/Scripts/Quilt.cs:484)
HoloPlay.Quilt.OnValidate () (at Assets/HoloPlay/Core/Scripts/Quilt.cs:270)


#2

Hi Greg,

That error you posted is a known bug, but should be harmless: it happens once on importing the SDK and never again, and it hasn’t (in our testing) caused a build failure. To try and reproduce your issue, I just created an empty Unity 2018.2.13f1 project, imported the SDK, opened the Example Scene, then built and ran the app with no errors, on Windows. It worked on my end.

Let me ask you a few more questions:

  • Are you on Mac or Windows?
  • Is this the HoloPlay SDK 0.1.4?
  • Was it an error while attempting to build that caused the build to fail, or was it an error on playing the resulting app?
  • What did the symptoms of the error look like? (magenta screen? garbled pixels?)
  • If the app built successfully, after running, can you copy the player log file and paste it here or send it to me?

Thanks! And sorry about the trouble with your project, we’ll get it resolved soon!


#3

I think it was just a busted shader. I opened an existing 2018.2 project and I got the error on import but the prefab worked, it was only the built in scene that did not work. Had I skipped opening the demo scene it would have worked. Windows, sdk 0.1.4, wouldn’t work on playing the built in scene, nothing displayed on the looking glass.