UI displaying on Primary display, not in Looking Glass display


#1

Hey all!

In the editor (Unity), my UI camera is displaying correctly with the Capture camera in the LG display, however when I run an executable, the UI camera defaults to my other (primary) PC display. Any clues as to what I’m doing wrong?

cheers!


#2

A quick fix:

  1. Go into the player settings for the project (Edit > Project Settings > Player)
  2. under Resolution and Presentation set Display Resolution Dialogue to Enabled.
  3. Then when your app starts, a dialog will pop up where you can choose on what monitor the app will run on (choose your Looking Glass monitor, obviously :slight_smile: ).

#3

Thanks Dez! Yeah, the dialog was enabled, and I had been selecting the LG display as my display to play on…but when I run the executable on the LG monitor, while the Hologram Capture camera shows on the LG display, the Hologram UI camera view still shows up on the primary (not LG) display. Hmm! Vexing! I just noticed that for all the demos in the Library, there are no 2D UI elements on the LG display. I wonder if it’s supported(?)


#4

Does your example scene in the SDK have a game object called “HoloPlay UI Camera”?
If it doesn’t, it’s probably an incoming feature. If you do have it, try that! :slight_smile: