Twisted and not 3D HoloPlay SDK test

#1

I have been trying to get the Looking-glass working, I followed the instructions twice with the same result. It seems to twist and have diagonal lines creep down in a screw-like fashion.

Thanks!
Chris

#2

Hi Chris!

Do you mind taking a photo of what your display looks like and sharing it here? We’ll be better able to diagnose that with an image!

That said, I want to make sure you have checked off all these boxes:

  • That all the cables you’re connecting are the ones that were shipped with your Looking Glass.
  • That your display settings are set to Extended and your Looking Glass display is set to 2560x1600 at 100%
  • Do a hard restart on your computer when all the proper cables are plugged in.

And just out of curiosity, are you directly plugging in both the HDMI and USB cables into your computer or are you using a display adapter of some sort?

Thanks!

#3

  • That all the cables you’re connecting are the ones that were shipped with your Looking Glass.
    Check!!!
  • That your display settings are set to Extended and your Looking Glass display is set to 2560x1600 at 100%
    Check!!!
  • Do a hard restart on your computer when all the proper cables are plugged in.
    Check!!!

Same issues I am plugging directly into the HDMI and the USB cables into the computer, no adapters.

I hope the image helps solve what is going on. Thanks!
Chris

#4

Hi Chris,

If you don’t mind, please run this slightly newer version of the Test Scene in Step 2 here and send over a photo: http://look.glass/gettingstarted

This will let us in the lab see if your system is reading in calibration from the Looking Glass correctly, or if it’s a display settings issue or some Unity windowing issue.

Looking forward to getting you up and running.

-Shawn

#5

Yep, I have HoloPlay-Test-0.2.7 and it has the same issue. I currently have been using my Mac to do all this, however, I think that I think I will try it on my windows machine. I have messed around with the settings to see if it would change anything. I personally wanted to use Blender instead of Unity but failed to find a tutorial or way to do it quite yet in Blender.

#6

Yep, the Blender plugin is currently being worked on and we’re targeting a closed beta release in the near future. Stay tuned!

#7

Hi there!

I noticed the same trying a fresh project in 2018.3. The game view menu didn’t quite get out of the way, so the view just never aligned perfectly with the screen. I switched back to 2017.4, and it works great!

I believe there were changes in the 2018 cycle that cause the game view to restrict its size and not display correctly when the HoloPlay SDK tries to do its preview thing. Has anyone at Looking Glass tried 2018.1 or above?

#8

I typically work on 2018.2 and that works fine for me, but I’ll ping @kyle to see if he has any insight here. I know he’s currently building out support for 2019, so I want to make sure we didn’t miss anything!