The Unity Preview and Double Vision [image jumping]

Hello All!

(forgive me for not introducing myself properly and just jumping in)

When working in Unity and toggling preview on the looking glass I seem to be having some trouble with parallax. Specifically, there seems to be a problem rendering the angle directly in front of the display, namely, when my eyes are parallel to the display. The rendered image “jumps” between viewing it from the left and right, without rendering the image as viewed directly “head-on.”

If I render the scene to file via AVMovie Pro Capture, or, if I load scenes via the Vimeo thing in Library, then there is no problem viewing the rendered image head-on. The problem seems to be confined to the Unity Preview, for now. As I was thinking of presenting some work on the looking glass via Unity next week, this display issue has me somewhat miffed. Does anyone have any ideas of what may be happening and/or how to fix this?

Thank you!

Mie

Hi Mie! Sorry for the issue! This is very likely an issue with scaling settings on you displays. Can you confirm that both your main display and your Looking Glass are set to 100% scaling?

Hi alxdncn! Thank you for the support.

In [System Preferences] on my Macbook Pro, the [Built-in] display settings are at a [Resolution] that is checked as [Default for Display,] which I assume is at a scale of 1.

In the same [System Preferences,] the [LKG…] [Display] settings are also at [Default for display,] which I assume is also 1, or, 2560 x 1600.

In Unity, the [Game] window is set to [Display 1] [Standalone (2560 x 1600)] [Scale 1]
When I change the this Scale value, it changes the scale of the [Game] window on my laptop, not the looking glass display. Previously, the scale value was at 0.569 to accommodate the real estate available on my laptop.

For a moment I did think that changing that Scale value to 1 was going to do the trick, alas. Any further input or questions would be greatly appreciated! I’m still under the impression that there may just be something really simple that I am overlooking. Even though I have some fluency with computers, this is my first time using Unity.

[edit:]

  • a video (4.3 MB, mpeg) to illustrate original condition

https://futurerelease.com/IMG_0623-MPEG-2_422.mpeg

Hmm, I’ll have to investigate this a bit further. It seems like it is definitely an issue with the Unity preview window.

We’ll actually be releasing a new version of the SDK (v1.2.0) later today. That has a bunch of improvements and handles the preview window quite differently. I’ll notify you when it’s live, maybe that will fix the issue!

Thanks for the update! Hopefully that will make a difference. The fact that others have not run across the same problem has me thinking… but I’m looking forward to the new SDK. Keep up the great work!

[edit:]

Upon further investigation it seems others have had similar results to mine, calling it an “image jumping” problem.

Tried the new SDK: same image jumping problem. AVPro movie capture does not produce said problem on final render. It is, however, a little expensive.