(RESOLVED!) Holoplayer Realsense camera stops finger tracking after just a few seconds


I am trying to run the holoplayer demos that came with the device. As soon as I start the demo, the realsense camera tracks fingers for 20-30 seconds, and then stop tracking my finger thereafter… The IR laser stops shining a couple seconds later.

I tried reinstalling the Realsense SR300 drivers, but it still doesn’t help. I’m running the demos on a Windows 10 machine with Intel Core i7- 5930 3.5GHz processor and NVidia GeForce GTE Titan X GPU.

Can someone tell me if this is a hardware issue?


Hi! I’ve seen this before on a prototype system, when either the USB3.0 connection into the holoplayer was loose or when a USB3.0 cable other than the included cable was used (specifically, a cable that is too long). Also for good measure, make sure you are running power to the system from the included 2A/5VDC adapter rather than from a USB port in your computer.

@samtim, any other thoughts?


I’m using the same cable that came with the kit
I tried plugging the cable into a different USB3 port, but I see the same behavior


Hm…we’re looking into it in the lab and hope to have a fix (or a couple more questions to hone in on whether the issue is hardware or driver related) tomorrow. We’ve thus far been able to get reliable performance with the supplied cables, so we’re trying to replicate this issue today/tomorrow.


Hi again! - we tested a system and cables from the same small proto production batch as your holoplayer and can’t replicate this issue unfortunately.

Please email me your order details at smf@lookingglassfactory.com and we’ll figure out how to get your system up and running well!


This is the system at Stimulant, order 614.

Maybe communicate about this with support@ our domain, the whole team is on that alias. Thanks!


Adarsh, maybe you can post a video somewhere showing the issue? That always helps.


Ah, great! Will get this figured out! And yes, a video would help!

Just to confirm @idealboy89 – are you plugging the main power for the system into the included 2A/5VDC power adapter, rather than into a spare computer USB hub? The power draw for the screen and internal speakers is right at the limit of what USB3.0 hubs from PCs can supply constantly. I doubt this is what’s causing the issue since this main power line is separate from the USB3.0 cable that connects the Realsense to the PC , but figured it’s worth a shot.


I just tried setting up the HoloPlayer on my Macbook. It seems to be working fine there.
Then I reconnected it back to my PC and realsense camera fires up the laser but, isn’t tracking fingers at all… Here’s a video

Here’s the Unity log after realsense stops responding

HoloPlaySDK Depth: Using device 0, an Intel RealSense SR300
Serial number: 629204005321
Firmware version:
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
HoloPlaySDK Depth: Depth stream initialized.
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
Setting up 6 worker threads for Enlighten.
Thread -> id: bb50 -> priority: 1
Thread -> id: d8a8 -> priority: 1
Thread -> id: d8ac -> priority: 1
Thread -> id: cff0 -> priority: 1
Thread -> id: da08 -> priority: 1
Thread -> id: ce88 -> priority: 1
HoloPlaySDK Depth: Stopping realsense plugin.
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
HoloPlaySDK Depth: RealSense error calling rs_wait_for_frames(device:0000000009402130):
Timeout waiting for frames.
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)


Also, I’m using the power adapter to power the Holoplayer


I looked up the error calling rs_wait_for_frames error online and stumbled upon this thread

Someone pointed that the issue is caused by the length of UBS 3.0 cable used . So, I used a shorter cable from another SR300 camera that we had in our office and it is working fine now…
It would however be nice to be able to use a longer cable (a powered USB cable may be?) so that we can set up the HoloPlayer a little more conveniently.


Hi! WHOA, your HoloPlayer’s visuals aren’t running correctly – that distorted test scene indicates that the calibration isn’t being read properly through the USB3.0 cable.

More here: HoloPlayer One Example Test

Your test scene should look like this:


Check to see if your a USB drive called “HOLOPLAYER” appears when you’ve plugged in the USB 3.0 cable.

Also, to work this out more quickly, you can call me at the lab at 929.387.8225 or Skype (shawn.frayne)!


Thank you for speaking with me on the phone.
I figured that it was some resolution related issue considering that I had the Holoplayer and my primary screen set in duplicate mode and a third display in extend mode.
Anyways, it seems to be working fine now. Thanks for your help again.
Here’s a picture of it working correctly. Please confirm if this is how it should look.


Yes, that is how it should look!

It’s tough to tell from the picture, but does the ball feel like it is closely tracking your fingertip? That is the desired effect, so we might have to walk you through some calibration tweaks if that isn’t the case :sweat_smile:

After our discussion, I thought it would be good to document the common Realsense issues we run into, so if you ever have trouble again, here’s the list for reference: Tips & Tricks: Why isn’t my Realsense working?

Thanks for reaching out and happy hologram hacking!!


Thank you for starting that thread. It’ll definitely be helpful for future developers who run into issues.
As far as finger tracking goes, it is positioned properly from the viewers perspective. Since it’s not a stereo image, it looks offset. But, in reality, it is being tracked properly.