[RESOLVED] Garbled, Sliced, and Warped: "No calibration data from Looking Glass"


#1

I received my much-anticipated Looking Glass display only a day ago. Sadly, I have been unable to advance past the Holo Play Test App. I am among the users afflicted with the Garbled Display. I triple-checked the Standard Looking Glass Setup Guide as well as the Troubleshoting Section of The Looking Glass Factory Wiki and combed the Support and Troubleshooting Forum Category for people experiencing similar issues and read them thoroughly. I was only able to find one that fit well, but there are still significant differences in our cases.

Most Similar Topic:
While my Garbled Display is the same in appearance, I have an older machine compatible with the provided cables.


Unlike user rzsombor, I have an older MacBook Pro (System Info Below) compatible with the provided cables.


Like user rzsombor, when I opened the test app, the display was garbled and accompanied by a series of zeroes. The support staff suggested that this meant the calibration data was not being read.

It is worth noting that these results did not change with subsequent testing.


I also tried opening the Library app to help diagnose the problem and got an error message that read “No calibration data from Looking Glass”


As per the error message and the solutions recommended in user rzsombor’s support thread I tried both a regular reboot, and a hard reboot without detaching the Looking Glass display.


When I had the library app open, I noticed that the image was not as garbled as the one in the test app, rather it had multiple diagonal slices. each slice seemed to be showing the full range of view, so in some of the previews there was what looked like a curvilinear display as well. Out of curiosity I played with the Underscanning options in the display preferences, this tightened the number of diagonal shears. It looked like I would be able to correct the issue entirely if I could set the slider to a value less than zero, or rather, if I could get the operating system to overscan rather than underscan.

The first image, featuring The Looking Glass Factory logo best demonstrates the diagonal shears, the second and third images best demonstrate the curvilinear distortions.


Unfortunately I do not own any other USB-C Devices, so I have not been able to test if the problem lies with the included cable. I doubt this, as the display shows an image, and ceases to function when either cable is unplugged from either end.

It is also worth noting that while three of the buttons are not functioning for me, the square button, on the far left is, and is functioning as a click, wherever my cursor happens to be.

I can still think of one or two more things to try on my end. If my efforts bear fruit, I’ll update the thread.

-RBM-


#2

Hi Richard,

Yup, that looks like a connection issue on the cable side or a USB board issue. I’ve got a patch and then a permanent solution in mind:

First to explain what you’re seeing: scenes look more garbled in the Test App than in the Library itself because the Library is reverting to a default calibration setting, but that default is still pretty far off from your hardware’s unique calibration, hence the warped result. This would be very hard to compensate for in any way other than with the device’s unique calibration - I don’t suggest tweaking your display settings to adjust this, since you may get close, but you’ll still end up with a significantly subpar experience. We are calibrating on a sub-pixel level, so the only way to really fix this is to get the device’s unique calibration to read into the host computer.

One question to help us debug this: Are you using any converters for your cables, or just plugging in the included cables directly into your Mac’s HDMI and USB ports?

And one more thing to try: please switch USB ports and then do a hard reset of your computer with the Looking Glass plugged in. Do this with the cables we provided.

Let me know if that helps or not. If not, please write me at shawn@lookingglassfactory.com with the serial number of your Looking Glass (on the label on the back of the unit) and I’ll get you your backup calibration file to try as a temporary bandaid and will work out getting you a replacement.

-Shawn


#3

Shawn,

Thank you, I wouldn’t have imagined something as simple as switching USB ports might have worked, but it did. The calibration and the library both came through crystal clear! I have to say, The Looking Glass is everything I imagined it would be. Shawn, what you and your team have accomplished is nothing short of incredible. Y’all should be very proud of what you’ve accomplished. Thank you for your reply, I’m sure I’ll be back on the forums, as I’m just a graphic designer, and the Looking Glass SDK is my first foray into development. If real life holograms don’t cause me to take the leap, what will?

Troubleshooting Follow-Up:
For others facing an issue like mine in the future, I suspect that a 3rd party system preferences panel might have been interfering as well, I read in another thread that the USB interface for The Looking Glass is read by the computer as a joystick. Months ago I had installed USB Overdrive (a 3rd party Mac extension for controlling Joysticks). I uninstalled it alongside following Shawn’s instructions. I may re-install it later to see if it was a contributing factor or not.

I’m not sure of how to mark the thread solved, or if that is something I do, of if Moderators mark it solved, but it is solved to my satisfaction.

-RBM-


#4

Thanks Richard!! Can’t wait to see what you create, and let me and others here on the Forum know if you’ve any questions as you dive in. Also don’t hesitate to email at shawn@lookingglassfactory.com if need be.

-Shawn