RealSense Camera not detected in Win10


I received my Holoplayer yesterday and did the setup as outlined. I tried some of the demos and everything was working properly, however, when I was using the Holoplayer today, I noticed the RealSense camera would initialize only some of the time. I uninstalled the drivers for the RealSense camera to then re-install the drivers, and now the Depth Camera Manager can no longer detect the camera at all. I am working on a Windows 10 machine.

Hey There Michael,

Sorry to hear of the problems. Can you tell us how you are trying to use the RealSense? Through just playing demos or trying to use through Unity?

We’ll get to the bottom of it soon!

Hi Benjamin,

I was using it for just the demos at first. I was going through the tutorial for Unity when I realized the camera was not initializing. After going back to test the camera on the model viewer demo, it still would not initialize. I tried all the standard fixes first, then figured it was an issue with the drivers. After I uninstalled the drivers, the intel DCM is no longer detecting it. I noticed in the device manager I now have a “usb camera” even though I don’t have any usb camera’s connected to it. I suspect that my computer now thinks the camera on the Holoplayer is a usb camera and does not recognize the IR camera? I tried uninstalling the usb camera device, then going back to the intel DCM, but this has not fixed the problem unfortunately.

Hi Michael,
The holoplayer camera does in fact contain both a ir camera and a normal camera.
If the drivers and windows recognize it correctly it should look like this in your device manager:
Imaging devices:

  • Intel® RealSense™ Camera SR300 Depth
  • Intel® RealSense™ Camera SR300 Virtual Driver

Also, keep in mind that in the current published SDK it is not possible to have 2 applications talk to the camera at the same time. This includes Unity. This means that you can’t have Unity connect to the camera while you are developing, and then have your build connect to it without shutting Unity down first. Visa versa is also true.
Future versions address this issue.

Hi Dez,

Thanks for the info. I am still having issues however. Imaging Devices does not appear in device manager at all actually. I have attached a screenshot of what my computer is showing in device manager.

My guess then is this is a driver issue.

The camera inside the HoloPlayer One is an Intel SR300 try reinstalling the drivers from here, restart, and see if it shows up:

  • If it doesn’t show up, make sure it is connected into a USB 3.0 port (they are blue inside).
  • Avoid connecting the HoloPlayer camera through a hub. But If you are, make sure it is a USB 3.0 hub.

Let me know if this helps.

HI Dez,

The DCM is still not detecting the RealSense camera. I am currently looking at solutions on the intel forums to see if I can find a solution. Below is an image of the error message I am getting when I try to install the drivers.

Yea we have seen this issue with the realsense and some computers.
Our hunch is that it can be a power issue (not enough power coming out of that port for the realsense).

Trying just different ports on the same computer or different computer might just resolve it.

Along the same line, if using another USB port on your PC still doesn’t work, we have experiences in which a USB hub drawing power right from the wall helped solving the power issue. Goes without saying that the signal of the USB hub needs to go back to the computer you are using.

Hi @Michael-Carter - good to chat with you just now! Please post here if those other fixes I mentioned and those that are being mentioned in this thread don’t work – one of us in Looking Glass will then hop on a call with you to make sure this is fixed.

Hi @smf just got around to testing all of the above methods. Unfortunately, still no luck…

Ok, pulling this into a separate email chain so we can debate with you over a Skype call. Incoming!

I’m having this same exact problem with the camera not being detected, so I can’t install the driver. (Also using Windows 10) What did the remedy wind up being for the above case?


Two things that I would double-check for:

  1. Please ensure that the RealSense cable is driving off of a USB 3.0 port on your computer.

  2. If the drivers and windows recognize it correctly it should look like this in your device manager:
    Imaging devices:

  • Intel® RealSense™ Camera SR300 Depth
  • Intel® RealSense™ Camera SR300 Virtual Driver

If you don’t notice this in your device manager. The drivers may have to be installed manually (usually, this happens automatically, but sometimes when there is no WiFi connection detected, it won’t do this.)

The drivers for the driver is below:

Please download the driver for intel_rs_dcm_sr300

If this still doesn’t work, happy to jump on a call with you later this week! A few of our team members are in HK right now but can schedule a time that works for you!

1 Like

Sent an email. Please set up the call. Anytime. Thanks.

I was also experiencing this issue. Should have asked myself if its plugged into 3.1 usb or not :man_facepalming:. After plugging into the correct ports the driver automatically installed.

1 Like

Oh, Goodie! Let us know if you need any more help! We’re here.

1 Like

I had a similar problem with the camera. This must end!