Please help! Going insane!


#1

I received my Looking Glass last week and after a few problems with garbled screen issues, I eventually had it running the Library demos beautifully. Now however, the screen is constantly garbled. I have checked the settings over and over again and they are all correct. I have also swapped USB ports etc. as per the troubleshooting advice. I cannot understand how the screen was working correctly three days ago, but now is a garbled mess!
Can anyone help?
I am running the Looking Glass on an HP ENVY x360 15-cp0000na Convertible Laptop, with an AMD Ryzen 5 25000U cpu, 8GB RAM, 1TB HDD + 128GB SSD and Radeon Vega Graphics card.
I know on the face of it that this would seem to be an under powered system, but it was working really well.SQUISHY%20SQUAD ![SQUISHY%20SQUAD|640x480](upload://gpPCvFuAMbhsTEST%20IMAGE ng2oV9fHy5iQvuL.jpeg)


#2

Could it be that the resolution at which you’re outputting to the Looking Glass has changed accidentally? Or did you check that already?


#3

Hi Paul,

Yes I have checked that the settings are correct many times, but still get the sliced display. I cannot understand how it can work perfectly last week, but now not work properly at all.
Would you know if there any settings of the graphics card that could be causing the issues?

Best regards,

Michael


#4

Weird, I don’t think underpowering can cause this, as you get a bright image over the full display. It still looks like a resolution mismatch to me, as for example the right-most part of the blue box is displayed at the left of it (and vice-versa), suggesting the pixel mapping isn’t done correctly.

But what I don’t understand is that the two lines of text don’t show the incorrect pixel mapping. So maybe there is something wrong in the 3D rendering only. Is this with Unity? And, if so, are there separate settings for controling the rendering the Unity SDK?


#5

Try swapping the hdmi ports if you can. Mine went completely black for a while until I swapped them. Some HDMI ports wont allow native resolution.


#6

Hi Michael –

This could mean that there’s an error with the USB communication. Maybe try some of the suggestions under “The Example Scene is garbled…” section in this post:


#7

Hi Paul and Ascensi,

I have managed to fix the problem.
I checked to see if Windows was up to date. I use a laptop now instead of a desktop, and so I forget that the auto update doesn’t always get done as the computer is turned off for a large part of the day and as a result it was not up to date. After a particularly long update, the Looking Glass worked without a problem>
I don’t know why it took an update to get it to work again, but i am not going to look a gift horse in the mouth!
Thank you for your help.
Michael


#8

Sometimes the most useful thing a Windows Update does is the restart at the end


#9

This is bizarre. The screenshot would suggest a calibration read error to me, but the last photo shows the serial number of the Looking Glass, which has to have been read from the calibration file.

We’ve had issues in the past with the 0.1.4 SDK failing to read calibration on Radeon Vega systems, but those were usually fixed by installing Intel Driver and Support Assistant. It looks like Windows Update took care of that step for you (small blessings :slight_smile: ).

Glad you got your system working, though! If you have any other issues, please keep us up to date - we don’t have a huge sample size of customers using AMD graphics.