None of the apps in the library can't be played or download

I just received the Looking glass, I downloaded everything needed, tried the test app and worked, but when I try to download or play any app from the Looking Glass Library nothing happens, it does not download anything, it does not play anything. I followed all the troubleshooting that I was able to find and nothing works any suggestions?


Hi Adria, are you on Windows or OSX? This is certainly unusual, we’ll try to get to the bottom of it. If you let me know your operating system I can find the error output log and we can see what’s up!

Hi alxdncn,

The I am running this in a Windows 10 gaming laptop, I managed to download 2 demos: “MasscatFollowBall” and “Art Bully”, for the others I click on download and then the loading bar starts to load but then it stops suddenly with a “beep” sound and nothing happens, and does not matter how many times I try to download them they always stop at some point.

Thank you!


Hi Adria, is this maybe a memory issue? The Library currently downloads all apps to the C directory, if you don’t have enough memory there it will not be able to download it. In an upcoming version you’ll be able to change the directory where things are downloading.

Hi, does not seem to be a memory problem, I tried having the library in C: with 100GB free and still not working, tried also having it in D: with 200GB free and still not working…

Hi Adria, are you using the newest version of Library(v0.4.0)? If not, please try updating to the newest one.

If this doesn’t solve the problem, can you send over the output log, which can be located at C:\Users\<username>\AppData\LocalLow\Looking Glass Factory\Library, to Thank you!

I’m having the same problem. I’ve tried it on my surface studio at the office and the exact same issue as above… Then I tried it at home on my VR rig which has plenty of resources. Same exact issues.

Hi @Zizuar, sorry you’re having issues! Do you happen to have multiple versions of the library on your computer already? @irreverentQ do you have any thoughts on this?

I’m having the same issue with the Library. I start to download, it says it’s finished and gives me the “Launch App” button, but when I push it, it say’s “download canceled”, and never let’s me play. I have tried waiting quite a while for the download, I have over 100GB available on my C Drive, I am running on a Windows 10 Gaming PC. The only app that I have been able to get working is Glass Galaxy. I tried uninstalling and re-installing the library too. Here is the log:

Initialize engine version: 2018.2.21f1 (a122f5dc316d)
GfxDevice: creating device client; threaded=1
Version: Direct3D 11.0 [level 11.1]
Renderer: NVIDIA GeForce GTX 1080 Ti (ID=0x1b06)
VRAM: 11031 MB
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.972 seconds
    Initializing input.

Input initialized.

Initialized touch support.

UnloadTime: 0.412700 ms
Current Library Version: 0.5.1

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

Current Operating System: Windows 10 (10.0.0) 64bit

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

Opt-out preferences successfully retrieved, applied and saved:

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

3D Words Display is ready

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

3D Words Display’s downloaded is cancelled

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

Hi there @dsfcl – sorry about the delayed note here.
Were you able to troubleshoot for this or can we still help out in any way here?