My own troubleshooting experience: Windows & Mac


#1

I wanted to share some of my experiences of successes and issues, in case others run similar situations.

First try: Windows 7 without USB 3.0 drivers

I wanted to call this out. I knew I did not have my USB 3.0 drivers installed yet (despite having the hardware there for some time). I was curious if it would still work. The result I found was that nope, it did not - but interestingly, it had the classic “garbled display” mentioned in the main troubleshooting thread.

So the callout: Really verify from device manager that you are actively running with USB 3.0 drivers.

After installing drivers

Test scene worked as expected first time

Macbook Pro 15 inch, 2017 model [first time]

This also worked out of the box without issue. Wish I could also run this with extended display! But in any regards. In this case, the device only has USB-C outputs, so I was using one adaptor from USB-C to hdmi, and another that was USB-C to USB 3.0, and then connected those with the cords that came with the looking glass.

Note my follow up note below about when this later stopped working again

Created my own unity app using the SDK

Just wanted to call out this worked right away and very easily! I was using Unity for windows, and then built for Mac on windows and that worked fine on my 2015 MBP.

MacBook Air 2013

TL;DR I haven’t gotten it working on this machine. This is a low powered, much older machine - but technically, the graphics card has the required resolution and indeed has USB 3.0 ports functioning.

I also tried with the active adaptor recommended in the main thread. Note the screen does recognize and flash as though connected to a monitor, and furthermore the resolution indeed changes to correct resolution. But regardless, the looking glass itself remains black/blank.

Tried again on Macbook Pro 15 inch, now flashes green

Having changed nothing else that I can recall, now when I plug in the connections the display with flash screen about once every half-second. It technically is still otherwise working (between these short flashes will properly render 3D scenes).

I restarted the machine several times, tried all different ports, tried installing updates where relevant. I tried using a USB-C to USB C cord directly (instead of USB-C to USB 2.0 adaptor into the 2.0-C cord that came with the Glass), which worked but still flashed green. Played around with scaling/resolution, all with no changes to the flashing green. I still haven’t figured this out, but would love to (it’s my work laptop, and want to show it off sometime at the office!)

Still works on Windows desktop machine

Initially I was afraid that the flashing green issue was a problem that arose with the looking glass itself, but low and behold it was working fine when connected back with my windows desktop machine. The device still flashes green with the MacBook Pro 2017 which is sad, but at least I have it working on my main windows machine.

I’ll post any updates if I make more progress, but also would love to hear if anyone else has run into this green flicker issue!