Leap Motion Controller not working

#1

Hi,

I just received my standard size Looking Glass and it displays fine! However, the apps don’t seem to recognize my Leap Motion Controller.

Please note that I did not order the Leap Motion with my Looking Glass. I already had a Leap Motion Controller. The Leap Motion Controller app indicates it is working fine.

Thanks in advance for any advice!

Regards,

telesun

#2

I am using my own leap motion controller too and it work fine.
Did you got any error message when you launch the app that leap motion support?
Mabe you can try the leap motion V2 Desktop SDK or win10 fix for leap motion.
I don’t know the correct steps but i had did some works above before it got work.

#3

I had the same result as @babyfish0226 (I used my own Leap Motion, installed some stuff, and it worked). Sorry I did not takes notes as to everything I installed. Weirdly, the Leap Motion demos don’t work, but the Looking Glass does use it.

#4

After further investigation, I think my problem has more to do with the limited power of my laptop (Intel i5 @ 2.2Ghz with 8Gb RAM) and graphics than any Looking Glass or Leap Motion issue.

If the graphics quality is reduced in some of the Looking Glass app, the Leap Motion Controller works! The higher the graphics quality, the more “laggy” the controller gets. At higher qualities, it doesn’t work at all…my original problem.

Thanks for the responses!