L3D Cube anyone? 8x? 16x? Bueller?

Hiya - Documentation and cube services can be found at cubetube.org.
What’s your issue with the cube? Maybe I can help if you can’t find the answer there.

Hi Esk:

Thank you for replying. Unfortunately, the reason I posted here is that I spent last week searching for answers on cubetube, but learned that the website has not been active for the past 3 years and it looks like even the forum was taken down.
I bought the 16x after I had spent a lot of time looking around for a cube that worked out of the box without the need for a lot of coding, which I don’t know how to do. I saw the L3D ads about the available programs you could download to the cube from the online community and thought it was what I was looking for. Now that I’ve set it up, I’m finding that none of that is available.
I think I might have been given the 8x photon because it came with 4 demos instead of the 5 that were advertised for the 16x - as well as the 8x instructions. So, I’ve instantly run into a brick wall.

I do have a little experience with addressable RGB LEDs, so I think I might be able to get it going if I can just find the right info and the correct photon. I was hoping to find answers on the forum but I can’t find it - so I’m hoping someone knows where it is.
Thanks!

Hi Oside – please write me at smf@lookingglassfactory.com and I’ll help get this sorted out for you. The community around the L3D Cube basically disappeared over the past couple years and lately we’re focusing most of our efforts in the team on the Looking Glass display.

I know that’s probably not what you wanted to hear. If the included demos on the 16x and 8x Cube you purchased aren’t what you’re looking for (we found that most customers of the L3D Cubes just want to run the included 4-5 demos believe it or not, which is the only reason we kept them available), I’ll process a full refund immediately.

-Shawn

I could also use some help. Trying to fire up my 8x8x8 L3D cubes after a long period of dormancy, and I’m running into some issues. Went searching on Cubetube to find the forums are dead.

I have a photon cube which I re-claimed with the iOS Particle app. Connected it to wifi with no problem, sending a 10-second signal from the iOS app works, and it shows up as an available cube (with the correct name) when I select a visualization on Cubetube. However, when I hit the “Send to cube” button on Cubetube, it stalls on “compiling…” and nothing downloads.

Is this a problem with the Cubetube gallery?

1 Like

Hey Oddity –
Particle recently changed some stuff in their API, and it broke some of the features on cubetube. I’m playing catch-up trying to get it back to normal. The ‘compiling’ error is a bit of a red herring – it actually is sending the program all the way to the cube, but I need to hook up the signal that I get from particle when the photon starts receiving the program to change the status from ‘compiling’ to ‘flashing’

It should be flashing your cube, though – it does when I test here. Does the LED on the photon underneath your cube change color at all? If not, it sounds like something is going wrong on our end and I’ll take a look.

Also, which viz are you trying? To control variables, can you test with a simple one that I know works, like the ‘Line’ viz that you see when you scroll down on the homepage?

Sorry for the hassle – we’ll get you back & blinking.
–alex

Appreciate the response. I had actually tried the very same visualization you suggested to minimize code complexity. I noted that the LED on the photon did not change color at all - it remained breathing cyan.

Ok, that sounds like it’s on our end. I’m traveling ATM and don’t have a photon on me but I’ll debug on Monday when I’m back and let you know when we’re back up. Sorry for the hassle

Alex: I have not tried to load the viz you emailed on the 5th. I’ll wait until Monday when you’ve tried your fix. Maybe this will clear up some of the difficulties I’ve had with the photon, as well?

No problem. Thanks for the help!

Hi. I’m having the same issue here. The viz I had loaded started failing so I tried to do what I usually do, reflash and reload from the gallery, but it gets stuck on Compiling. I found this other site on google, http://34.208.17.131, and that completes the flashing process but then it doesn’t work and the red light flashes…

1 Like

Hallo, ich habe das gleiche Problem, haben ich habe versucht von der Seite cubetube.org aus der Gallery neu zu laden leider funktioniert es nicht und der Photon atmet Cyan!

Was kann ich tun?

Hello, I have the same problem, I tried to reload from the page cubetube.org from the gallery, unfortunately it does not work and the photon breathes cyan!

What can I do?

Was there ever a resolution to the Cubetube “compiling…” stall?

Hey guys,

Is looking glass still a thing? Did this compiling error ever get fixed?

Mine died, got it back to “breathing cyan” but now cant get Spark Pixels back on it.

This thing was about $700AUD so will be pretty disappointed if its not going to work anymore??

looks like its even more now :frowning:

Common guys??? these things aren’t cheap.

Following up with some of the developers around the L3D cube now! We haven’t distributed these for quite some time - will do my best to investigate.

Thanks for that; but they are still being sold as new items. If you’re not going to support the devices anymore, you might want to buy the stock back or something. It’s unfair for end users, not to mention making Looking Glass look bad.

Hi @liminal thanks for the note. We definitely agree with you and will reach out to Seeed Studio about the matter.

I just tried to dust my cube off after a long period of sitting idle. It’s stuck with some awful animation I made years ago and forgot about. There’s an API error preventing you from logging into the cubetube console (even if you’re able to disable CORS), so I can’t fix it.

Hey LGF:
I’m excited to see the new products you’ve produced and totally understand why you don’t have resources to indefinitely support the cube. Could you guys please open source the platform or provide info on how we can still make use of these?

Hi @tiz.io, sorry you’re also having issues with the L3D cube.

We’re currently reviewing the state of our software for the L3D cube and are looking into the issues listed above. Please bear with us while we address them, apologies on that process going slower than we’d like! We will certainly consider making the software open source if it will help our community make use of our product. Thanks for the suggestion!

1 Like

Thanks for looking at this. with all the WFH I cleaned off my desk, and in the process unburied my cube. It was working fine, but I wanted to load different code, which failed from both usb and from the cubetube site. The cube doctor app for Mac I downloaded from this site (Google Groups ) worked to put back the default demo, when I got it stuck, but I wanted to actually put in some custom stuff. I totally get not supporting the web interface, but can some one point me at how to fix the usb loading software? My kids were interested in programming for it as well (they were a bit young for that 5 years ago).

thanks for any pointers.