In Unity the preview is on the wrong screen

I work on Windows10/GTX1070. The problem is, no matter what I do, the preview ends up on my main screen and does not go to the looking glass. In the display settings The LookingGlass is [ 1 ] the main monitor is [ 2 ]. I can not change that. It does not matter if the LookingGlass is left or right. The LookingGlass overwrites somehow what [ 1 ] was befor - I can not change this.

Is there a way to manually change something? It would be enough, to move the preview window by numbers, but I can not find a option to do that.

I work with the latest version of the SDK, it is 1.2, just downloaded it. Would love to know what I could do, have to finish a project right now, so there is also a bit of pressure :confused:

1 Like

I also have this error in the console:

[Holoplay] No LKG display detected UnityEngine.Debug:Log(Object) LookingGlass.Holoplay:OnEnable() (at Assets/Holoplay/Scripts/Holoplay.cs:190)

I’ve had similar issues when developing for looking glass. You should enable the resolution dialog box, since it lets you pick the monitor that it displays on. Additionally, I found that changing the display of the looking glass in Unity helped. At one point I remember realizing that the display it was displaying on was technically #2 according to Windows, but in Unity I was having to assign it to #1.

Once you’ve enabled the resolution dialog box and picked the right monitor, rebuild the program without the resolution dialog box and Windows will remember which screen to open you program on automatically.

Hmmm that error is strange. You’ve enabled the hololens preview under options (i believe that’s where the setting is - one of the drop down menus at the top of the UI)? You plugged both the usb cable and the hdmi cable into your computer? Additionally, you’re using the special camera that comes with the looking glass sdk right?

have you tried running the demo games that come for free with the looking glass?

Same problem…

Hi Folks –

Sorry for not responding earlier. Please see the answer below. This will be integrated into the official docs shortly:

Typically the HoloPlay SDK can figure out where your Looking Glass is positioned on your virtual desktop. Occasionally, however, this automatic function may not work.

To position the preview window manually, follow these steps:

  1. Under the project window, click Create → Holoplay → Manual Preview Settings


    The newly created HoloplayPreviewSettings asset will be created automatically and selected, and its properties should be visible in the inspector.

  2. Find out where your Looking Glass is positioned.

  • On Windows, this can be done by hitting the Windows key and typing “Display Settings”
  • On Mac, this can be done by opening spotlight (cmd + spacebar) and typing “Displays”

One of the monitors shown here is the Looking Glass (it won’t be extremely obvious, except that the recommended resolution for the Standard will say 2560x1600 and for the Large will say 3840x2160)

You can drag the virtual displays around to whatever arrangement makes sense, but it will make things easier if you ensure the top border of your main display aligns with the top border of your Looking Glass.

  1. It won’t say what the virtual position of the Looking Glass is, but you can guess easily. The top left corner of your main display is (0, 0). So for example, if your Looking Glass is to the right of your main display, and your main display has a resolution of 1920x1080, your Looking Glass preview window position should be (1920, 0).

Enter that number into the manual preview settings in the inspector and you should be good to go!

Untitled(1)
Ensure you do not delete the HoloplayPreviewSettings asset from your project, or move it to a different location in the hierarchy. It is necessary to be in the root of your project folder for the Preview.cs class to locate it.

Albert, tried your script. The “No LKG detected” is fixed but still getting “No LKG detected for extended UI”. -Tom

I’m worried there’s actually a different issue here. If it said before “No LKG detected” that means that it wasn’t getting some necessary data from the HDMI. If it says “No LKG detected for extended UI,” that’s a specific error message from our ExtendedUI script. Are you using that script?

Yes I am using the Extended UI script.