In Unity, Preview is offset to the side

#1

My HoloPlay Preview window in the device is offset to the side - which side depends on whether I have the screen set to the left of my main screen (offset to the left) or the right side of my main screen (offset to the right). Builds work perfectly, this is just the Preview in Unity.

LookingError

Holoplay SDK 1.0, Unity 2018.2.12, Windows 10. In other forum posts there was some options screen under the Holoplay menu in Unity, mine only has the “Toggle Preview” option, no Position or Presets buttons.

Edit:
I found an undocumented (as far as I can tell) solution - you can now right-click in the Project, choose Create->HoloPlay->ManualPreviewSettings. And that object lets you manually choose the screen offset (I needed -2022, -68 to make mine full screen centered).

#2

Check your monitor layout; IIRC, the Looking Glass should be to the right of your Primary (and should not be primary).

#3

You need to check primary display Windows settings - make sure 100% scale&layout is set here, double check LKG settings 100% as well.
After settings this while Unity running before toggle to LKG problems with shift went out.
This is pure Windows issue.

#4

BTW HoloPlay SDK 0.1.4 reccomends LKG on left. Used for my use case and resolved shift issue.

#5

I had the same problem, but resorted to offsetting it. I can still see my task bar at the bottom though. Whats going on with this? It isn’t too big of a deal, but if I can avoid having it there on the LG that would be great! Anybody know any solutions?