I’ve tried a few things but HoloPlayService doesn’t seem to work on my MacBook Pro. It’s definitely powerful enough, and running the latest OS (Catalina) - but I double click or right-click/open and nothing happens. I’m sure it’s a simple thing but if anyone can assist?

Hi, I don’t have much experience, but since the forum doesn’t seem to be well visited (at least in the past two weeks not many answers appear), I’ll give it a try. I also have a MacBook Pro (2016) on Catalina. Just to be sure: The app opens in the menu bar as a symbol only, so no window or anything else appears. Can you check, if it really didn’t open?

If no symbol is there: Which version of the Service did you install? If you open the Activity app and right-click/open the HoloPlayService app, can you see any HoloPlayService task running (maybe as “not responding” or whatsoever)?

Thanks there - yes after posting I realised it opened in the menu bar rather than a regular app. So I have it working - some of the images in the gallery are amazing - some a bit ‘meh’. Just need to work out how to make the images now! Thanks for replying.

Glad to hear that! Then have fun with making your first images! :slight_smile:

I’m trying to set up the glass display on a PC. How do you know if the HoloPlayService is working? I follow all the steps and hit RunTest on the website and nothing happens. No logo begin shown on the glass. I was able to run all the apps on Library site by assign unity to run on 2nd display.
Another problem with Unity package, Unity 2019.4 got stuck on importing HoloplaySDK-1.3.1.unitypackage. I had to kill it in task manager. Tried it on Unity 2018.3 and had the same issue.
Help please!
Thank you,


Hi Doug,

I don’t have it running on a PC / Inder Windows. But first thing I would do, is checking if you find a Running process called „HoloPlayService“ in the task manager. However, if all the Library examples worked, then the HoloPlayService must run.

You can also check out the „Quilt Images“ in the „made with looking glass“ section of the Website. Do they display?

Regarding the Unity problem, I unfortunately have no idea.

Best regards,

I can see HoloplayService in task manager. Can’t right click on the icon on task bar though.
Non of Quilt images in “made with” section work. Just say “loading…”
I got Unity to run sample project without holoplayService running in background nor glass turned on. As soon as I turn on the display glass and run holoplayService, Unity will lock up when run the sample scene.

I can right click on the holoplayService icon after initial install only if the glass display is off.


For some reason HoloplayService is disabled when USB cable is plugged in.

That sounds strange. Did you try other USB ports? Are they USB 3 or USB 2?

I did try different ports on my laptop. They’re USB 3. I’ll find another computer to run it on and see if having the same issue.

Another thing to clarify: Does your Lookingglass actually work as a second monitor properly? So, if you connect it (without the HoloPlayService running) - does it turn on is recognized by your PC?

What kind of Laptop do you have?

I tried running HoloPlayService on both Asus ROG laptops Nvidia 1070 and 1080 that I have. Holoplaysevice locked up once the USB cable is plugged in on both laptops. I tried it on an older Mac laptop and it runs just fine. Unity works correctly. BTW, I just installed newest holoplayService 1.1.2 and still had the same problem.

Looking Glass does work as a second monitor. On my newer laptop, I had to go to Nvidia settings to set glass display refresh frame rate to 30 Mhz or it won’t detect second monitor.

Okay, I think I found a workaround. It’ll work if I have display setting as duplicate then start the HoloPlayService. Switch display setting back to extended display to see things properly on looking glass. Something with starting up with extended display option that HoloPlayService doesn’t like.

Good that you found a solution. However, it makes me a bit suspicious that you see the same behavior on all your PCs. I would expect, that there should be no problem with starting the Looking Glass as extended monitor right away. At least on Mac, there is no problem with that.

Maybe you should write to Looking Glass support directly? Just to make sure your LG is fine!?

Thanks for the advice. I thought I would get the official support in this forum. No?

Same problem here. Thanks for finding the workaround @dougmp!!!
Just in case it matters … the system is MSI Raider GE63 with a RTX 2080 super.
Should I reach out to the support team as well?

Looking at older forum threads, the looking glass team answered a lot to give official support. But at least the moment, this doesn’t seem to be the case. :man_shrugging: There is a contact form:

@F31ix: I would reach out and ask them - just to be sure. :wink: Or you wait for @dougmp to share his response from the team. But as I said: I can only judge from what happens on the Mac and I don’t know what the normal behavior under Windows is supposed to be.

You’re welcome F31ix. I’ll try to email the marketing guy directly and see if I can get a response, just have to find his email somewhere in my inbox.