HoloplaySDK 1.3.1 Installation Problem

During unity package import of HoloplaySDK-1.3.1 I get the following error. Any idea how it should be handled?

“Copying Temp/Export
Package/ac79…/038…/asset to Assetes/Holoplay/Plugins/Windows/HoloPlayCore.dll: Access is denied.”

image

Ran Unity3D as “admin” and the install succeeded. Clumsy.

Can someone from LGF confirm that this error can be ignored. Or if not, tell me how to proceed. I’m getting different behavior from LG in Unity Editor mode vs Built App and I’d like to be sure it isn’t because of a bad Holoplay 1.3.1 install.

image

Hi @tskillman, sorry this issue slipped through the cracks! I’ll have to log this with the team, I’ve not seen this issue before.

Just to confirm, you’re running the Unity plugin on a computer with limited permissions, correct?

Follow-up…
I didn’t hear from LG for almost a month, and because my Unity app would run in Editor mode but not after Build, and because I couldn’t tell if it was from the 1.3.1 install problem or not, I verified that the problems was with 1.3.1 and not my code by duplicating the build problem with one of the Holoplay Demos.

This is as simple as I can make it.

These are the steps and results:

  • Running the latest Windows 10
  • Updated the HoloPlay Service to 1.1.2
  • With the latest UnityHub created a new Unity3D V 2019.1.2f1 Personal project.
  • It defaults to SampleScene, with a camera and a light game objects.
  • Imported HoloplaySDK-1.3.1.unitypackage. (half the time it gives a write permissions error during install, but not this time)
  • Dragged the Holoplay Capture prefab into the game hierarchy.
  • Deleted the default camera.
  • Create a simple cube and put it in the HoloPlay area.
  • Ran in editor more; it renders fine, after toggling the display (ctrl-e)
  • Stopped the run
  • Built the app and ran it, and it is runs and renders on LG fine
  • Stopped the app
  • Drag the ExtendedUI prefab into the game hierarchy
  • It comes with a default display element, a Button. I made no changes
  • Ran in editor and it renders fine on LG
  • Built the app and ran it, and it is NOT fine
  • It gives a clipped and shifted 2D display on the LG device
  • This is identical to what happens in my full ConfocalLG-V3 app

I found another LG user that followed this procedure and verified the result.


Because I never heard back from LG, I was forced to separate my code base into a VR version and an LG version, which is hell for the large amount of code base overlap.

In the standalone LG version I took all VR related code out and reset all Unity VR/XR setting. App Build and execute still not working.

I updated from Unity 2019.1.2f1 to Unity 2019.4.8f1. App Build still not working.

Reverted to Holoplay 1.2.1, modifying my code as necessary, made no reference to Holoplay Service or Holoplay Core. App Build finally worked.

Based on the high cost to me of trying use the latest versions of LG software, I will be staying with 1.2.1 for a long time.

*** Warning to other Developers, it seems that LG is supplying partially tested code, with limited support for problems their changes introduce. ***

Fair enough @tskillman, sorry you hit this issue and had to come up with a workaround! In future, if you don’t get a response here, please email us at support@lookingglassfactory.com.

We’ll note this issue on the Extended UI script and will take a look at our QA process on the plugin - not much I can do for you now, but we’ll try to learn from the mistake.

I’m still quite puzzled by the permissions issue on import, but I’ll log that as well and see if we can reproduce it.