Help with first scene please

#1

Still working on my first scene. Got models, sounds, particle effects and everything loaded and when I play the scene in Unity everything loads and plays and loops just fine. The problem I am still having is that when I build the project and I run it directly on my lookingglass the scene does not start, all of my models and animations and effects don’t start automatically and I don’t know how to program that or add an input command on my project like “press start to start” the only thing that loads automatically just fine is the audio file for the background music. ANY help will be greatly appreciated! Thanks

#2

Verify that the scene is getting included in the build. It should be checked on the “build settings” dialog.

#3

Thank you, unfortunately it is already included in the build settings dialogue box. Is there perhaps somewhere a setting to have the scene auto start? Similar to what the audio files have? My audio is the only thing that does start? Or perhaps a way to create a command like press space to start maybe?

#4

I should add that i can see my models on the looking glass when i run my project, they are just static the scene just doesnt start only the audio.

#5

Are they animated when in the editor? You might need to set up an animation controller. That will cause them to play (as long as that’s what you configure the animation controller to do).