Garbled image

#1

Hello.

Im trying to get this thing to work and i always get the garbled image:

I went through the quick start guide.
The resoultion is set to 2560x1600, 100% scaling.

I’m running windows 10, with all the updates. Im using the original cables that came with the display.

Also when i run the Library app it say that the device is not detected.

Any ideas?

#2

Hi! It looks like there’s an issue with the connection to your Looking Glass, which means we can’t load the correct calibration.

Is you Looking Glass plugged into your computer through the USB? Or have you plugged it into an external power source?

#3

Hello!

I have it plugged in my USB 3.0 port.

Are there some drivers i need to install, since windows is not doing it automatically?

Thanks!

1 Like
#5

@mk507 for what it’s worth, i found some of the tutorials had not-so-correct information and had to play with the system and unity settings a bit to get things looking correct. though if the library app is telling you that, it does sound like something else is going on.

#6

This shouldn’t be a driver issue - we don’t really require drivers for the Looking Glass base applications. It seems like, for whatever reason, the calibration isn’t being loaded. Are you using the USB cable that came with the unit? Sometimes the USB port has some issues and you may need to restart your computer, that might fix it as well. Additionally, if you could try it on another computer, that would tell us if it’s the system or the connection to that specific computer!

#7

Thanks for jumping in here! If you know of any tutorials with inaccuracies, please let us know and we’ll do our best to correct them!

#8

it was just a lot of clicking around. settings in unity were not being applied on save (in 2018.3). or we’d have this or this issue in unity, but library apps would look ok. or i’d change the settings to match https://blog.lookingglassfactory.com/getting-started-with-the-holoplay-sdk-for-unity-in-the-looking-glass-5e915b49db15 exactly, and it would reduce the flickering in unity, but then the library apps would look garbled.

at one point (i think after a unity editor restart) it all ‘just worked’ and i haven’t touched it since. currently my settings for the looking glass display are similar to what’s in most of the guides, but at a 3840 x 2160 resolution (which also is tagged as ‘recommended’ in the Windows’ display settings). this contradicts what’s here, i’m not sure about other guides.

the printed instructions for installing the base plate are also reversed; you should ‘push up’ rather than ‘pull down’ if the glass is (safely) facing up -> i noticed in one of your older videos you demonstrate installing it with the glass facing down, in which case you were ‘pulling down’ :wink: cheers!

1 Like
#9

Smaller display is 2560 x 1600; larger display is 4096 x 2xxx (too tired to look it up). Sounds like you have the larger one if it is claiming 4096 is native resolution.

#10

it is the larger display, though it’s claiming (and displays correctly at) 3840 x 2160

#11

Could be that, or maybe they use two panels. I only wish I had a large display. Someday.

1 Like