Garbled display in Unity Preview


#1

Hi. I’m trying to get going in the Unity SDK. I’ve got the latest of Unity, the SDK itself, and my video drivers (Nvidia 1060 on Win10/64). The sample programs run great, but when I do a preview in Unity, it’s all garbled. I have checked many times, and the display settings are all correct as detailed in the tutorial. The placement is correct as well, upper left relative to the main display as recommended. I’m not sure what else to check, so I would really appreciate some advice. Thank you.


#2

Hi Kelly! That does look like a case of something not being right in the display and toggle preview settings so if you could maybe do a screenshot of what your PC display settings are (under Settings > Display settings) and also Toggle Preview Settings (via your Unity editor under the HoloPlay Menu), that would be super helpful. Here are my settings:

Holoplay%20preview

and when I hit CTRL+E, everything does look correct.

Sometimes, the HoloPlay preview settings don’t save and so please make sure that the values you input (-2560, 0) are correctly in place! Let me know how this works out for you! Also tagging @kyle here to make sure we have all our ducks in a row too :slight_smile:


#3

OK, here’s my screenshots. As you see, they should be correct.

preview

The values in the preview settings are saving just fine. It’s just not rendering to the LG properly for some reason.


#4

Hi Kelly, can I ask what version of Unity you’re using? We currently don’t support Unity 2019, so I’m just making sure you’re on an earlier version than that.

Also, it’s possible that, if your main monitor has it’s scale set to greater than 100%, it may cause the preview window to be distorted. Perhaps this is causing the issue.


#5

2018.3 is the latest release of Unity. Is that the version that you don’t support yet?

I am running Looking Glass on 2018.2.11 with some quirks but no real problems.


#6

Well, I don’t know why this worked, but I deleted Unity and reinstalled (it’s 2018.3.0f2 btw, not beta), and now it’s happy as a clam. Probably something hosed on my end. Anyway, it’s off and running, and I’m gonna see if I can fire up a quick demo for this weekend. We do VR hackathons for high school students in the area, and I believe I’ll have this along for display purposes. Thanks for your help!


#7

There is an Alpha version of Unity 2019, @Dave, that some users have tried out with our SDK so I was making sure we were talking about the same version, just in case!

Glad this is working now! We have confirmed functionality on 2018.2, but we haven’t extensively tested 2018.3. Please let me know if you run in to other issues @Kelly_Luck!