Flickering Issues with HoloPlay-SDK


#1

Hi, my name is Giancarlo de Pinto, I’m a 3D Generalist and I’ve been working in the field of autostereoscopy for several years. The company witch I work for, purchased The Looking Glass to develop Interactive Applications with Unity. But I noticed that, if The Looking Glass is used with the basic applicationss, such as HoloPlay-Test-0.2.7, works perfectly, the flickering zone is peripheral (Image 1); however, if I try to develop Unity with your HoloPlay SDK, I have noticed that the flickering zone is no longer pergheric but you can see it in the areas indicated in the Image 2. I did not understand if you have inserted parameters that allow the alignment of the interlaced image with the refractive lenses of the Glass, so that make possible to calibrate the alignment of the images and then move the angles of the flickering in such a way as to obtain a situation similar to your HoloPlay-Test-0.2.7 (Image 1).
I noticed in the HoloPlay-Test-0.2.7 application, that you placed a Marker for Allignment (Image 1) that doesn’t exist in the HoloPlay-SDK-0.1.4 Unity Package, it would be perfect if you’ll release the complete SDK with allignment tools that I think you have already developed.
I hope to have as soon as possible your advice on how to fix this problem, thank you!


Unity SDK and split stereoscopic effect?
#2

Hi @depintogiancarlo, sorry you’ve been having issues! I have a few questions for you.

Are you seeing this issue with the “flickering zone” in the editor or in a build of your own project? It looks like there’s an issue either with it loading calibration (though, to be honest, I’d expect more visual artifacts if that were the case) or perhaps screen alignment. And are you working on a Mac or Windows machine?

As for your suggestion for the example scene in the SDK, I’ll flag @kyle on that as he’s the lead developer on that tool!


#3

Hi @alxdncn,
In the meantime, I have found a trick to avoid the issue disabling my third monitor; I usually use two monitor, plugging in The Looking Glass I arrived up to three; so it works fine if I use two monitor (first monitor and The Looking Glass).
By it’s a trick and not a solution.
I answer to your questions:
I’m seeing the overlapping of the firt and last images (45), what I call “flickering zone”, during the editing, instead the build works fine, so isn’t a big deal but if it would work fine even in editing it will be simpler to check the final result. I work on Windows. I think this is a problem usually caused by shifting of the interlaced images but it’s weird witch it depends on using three monitor or not… like I said I have some experiense in autosterioscopy but of course maybe I’am barking up the wrong tree.
I ckecked The Looking Glass resolution and it’s 2560x1600.
In addition I would like to emphasize the usefulness that you’ll expose alignment parameters to set the shift of the interlaced image with looking glass lenses (simply a Shift of the pixel columns of the 45 images interlaced) to be able to take advantage of what for me was a problem; an example could be use the looking glass in conjunction with facial tracking software to identify the position of the observer to dynamically move the pheriferical flickering zones so “cancel them”.


#4

Right, so the issue then is that it’s misreading what display it’s rendering on in the editor.

You should be able to customize the editor settings on Quilt component of the HoloPlay Capture object. There’s a button called “Settings” which will allow you to set a custom position for your Looking Glass preview window!

As for exposing the center value to allow for something like face tracking, you can change the value of the center in the Quilt config. We’re going to be releasing more thorough documentation in the next couple weeks that should help you get this up and running!