HoloPlay Preview Letterboxing with WMR HMD


#1

Hello all,

I’m working with both the HoloPlayer and a Windows Mixed Reality headset, creating a 2-player experience between the HoloPlayer and the HMD. Each of these two are working well on their own, and all SDKs and drivers are recognized and working in other circumstances.

In the editor, I have only a Main Camera, and the HoloPlay/Realsense prefabs. I am able to correctly align the HoloPlay preview, and before turning on ‘VR mode’ can run the scene with accurate detection and visuals on the Holoplayer. However, after changing the build settings to enable ‘Virtual Reality Supported’ running the scene adds a letterbox to the HoloPlay Preview, bringing the display to a 1:1 aspect ratio.

The Preview looks find during editing, it is only during runtime when the issue occurs. I believe it is using the aspect ratio of the HMD and applying that to all displays, but I am not certain nor do I know how to change that. I have tried changing the cameras to ‘Display 1/2’ with no changes.

Building the game (on Windows/Mac Platform) does not have this same issue. I can Build & run in the meantime, but ideally I would be able to have proper playback in the editor.

Any help would be great!

Mike


#2

Hey Again!

In the past, one of my own projects was-is actually a 2-player experience with HoloPlayer and Vive. So I can respond in hopes to overcome the in-editor issue that you have.

From what I understand, a special VR mode of the HMD distorts the display of the HoloPlay Capture breaking it from the original alignment (which should be right by default).

This could be solved, generally speaking, in two ways-

1.) Piloting the HMD commands to not affect all displays somehow. I would hope that there are options available on the HMD’s end to keep that command binary from the HoloPlay Capture.

2.) If that fails, it is possible to consider readjusting the alignment (right, or setting a custom resolution) after the editor VR mode initializes. Doing that through possibly accessing the HoloPlay Capture from another script. (Of which on that particular script, add a “using HoloPlaySDK” line at the start of said new script and then accessing the script itself to adjust its variables. SEE FIG 1
2b.) Start with HoloPlay Capture disabled and then enable post-VR mode initialization. An easier version of above. I just did a small test of enabling-disabling HoloPlay Capture Editor runtime and it worked. My hope is that with it disabled, it can not be affected by the VR mode initialization.
2c.) Not really a technical solution, but workflow suggestion. While developing, work on two different modes separately (replace HMD with a cube representing HMD cameral vice versa) so it does not slow down production. And as you mentioned, builds are fine.

FIG 1 EXAMPLE OF ACCESSING HOLOPLAY CAPTURE FROM ANOTHER SCRIPT

Let me know if that is of any help.

And also, I would be curious to know more about this project you are doing!

Here is the Vive x HP1 experiment that is ongoing here: "After Journey": A Vive and HoloPlayer One Project + Concept

-B.